Exchange Online Service Alert - cannot edit existing policies in S&C center
Incident Report for Zix | AppRiver
Resolved
Exchange Online service alert

Advisory information
Title: Admins can't edit existing retention policies in the Security & Compliance Center (SCC)
ID: EX315638

Status
Service Restored

Details
Title: Admins can't edit existing retention policies in the Security & Compliance Center (SCC)

User Impact: Admins couldn't edit existing retention policies in the SCC.

More info: A viable workaround was to edit existing retention policies through PowerShell.

Final status: We've reverted the bad code and confirmed through our telemetry that impact is mitigated. Users must refresh their user interface before they are able to use the service as expected. Please contact our support representatives if impact persists.

Scope of impact: All admins attempting to edit retention policies were impacted.

Start time: Monday, January 17, 2022, at 9:02 AM UTC
End time: Tuesday, January 18, 2022, at 10:30 PM UTC

Root cause: A code issue was introduced in a recent update meant to optimize some Microsoft Teams channel functionality.
Next steps:
- We'll continue to look into what within the recent code change led to impact in order to improve our code development and testing phases to avoid repeats of similar impact in the future.
This is the final update for the event.

Thank you,
The Microsoft team
Posted Jan 19, 2022 - 07:11 CST
Update
We are continuing to investigate this issue.
Posted Jan 18, 2022 - 16:29 CST
Investigating
Exchange Online service alert

Advisory information
Title: Admins can't edit existing retention policies in the Security & Compliance Center (SCC)
ID: EX315638

Status
Service Degradation

Details
Title: Admins can't edit existing retention policies in the Security & Compliance Center (SCC)

User Impact: Admins can't edit existing retention policies in the SCC.

More info: A viable workaround is to edit existing retention policies through PowerShell.

Current status: During reproduction of impact within our test tenant, we were able to narrow down the root cause to a code issue introduced in a recent update meant to optimize some Microsoft Teams channel functionality. We're reverting the update that includes the problematic code and expect it to be complete by the next update time.

Scope of impact: Your organization is affected by this event, and all admins attempting to edit retention policies are impacted.

Root cause: A code issue introduced in a recent update meant to optimize some Microsoft Teams channel functionality.

Next update by: Wednesday, January 19, 2022, at 1:30 AM UTC

Thank you,
The Microsoft team
Posted Jan 18, 2022 - 16:28 CST
This incident affected: Office 365.