Inbound Phone Issues
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 15:47 CST
Update
We are continuing to investigate this issue.
Posted Dec 14, 2023 - 15:46 CST
Investigating
We are investigating reports of issues with our inbound support numbers when calling. For support assistance, please email to support@appriver.com or support@zixcorp.com.
Posted Dec 14, 2023 - 08:36 CST
This incident affected: Support Infrastructure (Phone System).