Unable to access DeliverySlip web portal
Incident Report for Zix | AppRiver
Resolved
The issues that were reported with being unable to login to the DeliverySlip portal's has been resolved.
Posted Sep 26, 2023 - 10:04 CDT
Investigating
Our engineers are currently investigating issues with users not being able to login to the DeliverySlip portal.
Posted Sep 26, 2023 - 09:44 CDT
This incident affected: Encryption Services (EMP/DeliverySlip).