Information Archive/Erado Archive
Incident Report for
Zix | AppRiver
Resolved
This incident has been resolved.
Posted
Aug
06
,
2024
-
17:33
CDT
Investigating
Archive related platforms and management tools are not accessible at this time. Our Engineers are aware and working to resolve the issue as soon as possible.
Posted
Aug
06
,
2024
-
15:40
CDT
This incident affected: Archive Services (Information Archive / ZCP, Erado Archiving).
×
Subscribe to Incident
Subscribe to updates for
Information Archive/Erado Archive
via . You'll receive .