Hosted Exchange delivery issue
Incident Report for Zix | AppRiver
Resolved
We have confirmed the issue for the subset of users was resolved and all emails were delivered. It appeared to effect a subset of users on our Hosted Exchange platform location in our Switzerland data center.
Posted Jan 15, 2024 - 11:10 CST
Investigating
We are currently investigating an issue in which a subset of users are effected by emails not being delivered into their mailboxes. We have escalated this issue and working towards resolving as soon as possible. We apologize for any inconvenience this may be causing.
Posted Jan 15, 2024 - 07:15 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).