Customer Portal Error
Incident Report for AppRiver
Resolved
We have resolved the issue with the Customer Portal. We apologize for any inconvenience this may have caused.
Posted May 05, 2022 - 18:33 CDT
Investigating
We are currently seeing issues with the Customer Portal giving a "Oops something went wrong" when attempting to log in. We are actively working on resolving this issue. We apologize for any inconvenience this may be causing.
Posted May 05, 2022 - 14:33 CDT
This incident affected: Secure Cloud Platform (Customer Portal).