New Support Process to Authenticate Callers for Phone Support
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 07:18 CDT
Identified
In an effort to help provide the best security for our customers and their data, on Oct 2, 2023, all callers that contact Support will be required to be authenticated before the call will proceed.

Please understand this new process has not been put in place to create any inconvenience, it is to create a better layer of security of your account and data.
Posted Sep 13, 2023 - 12:42 CDT
This incident affected: Support Infrastructure (Phone System).