Microsoft Service Alert One Drive
Incident Report for Zix | AppRiver
Resolved
September 9, 2021 11:44 PM
Title: Users' OneDrive for Business storage limits are lower than expected



User Impact: Users' OneDrive for Business storage limits were lower than expected.



More info: For users that were impacted, any quota which exceeded the 1TB storage, users may have only been able to see their content in read-only mode.



Whilst in read-only mode, users were able to access their content in OneDrive for Business, but were unable to make changes.



Instructions to manually set quotas could have been found here: https://docs.microsoft.com/en-us/onedrive/change-user-storage



Final status: We've completed our mitigation efforts and confirmed that the issue has been successfully resolved. We appreciate your patience during the duration of this incident.



Scope of impact: This issue affected a large subset of users worldwide, who have a storage quota that exceeds 1TB.



Start time: Tuesday, August 24, 2021, 9:31 PM (8/25/2021, 2:31 AM UTC)



End time: Thursday, September 9, 2021, 11:30 PM (9/10/2021, 4:30 AM UTC)



Preliminary root cause: A misconfiguration resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.



Next steps:
- We are reviewing our change management process and monitoring in the quota management components in order to harden the system from taking action on invalid or erroneous signals.
Posted Sep 10, 2021 - 14:07 CDT
Update
September 8, 2021 5:05 PM
Title: Users' OneDrive for Business storage limits are lower than expected

User Impact: Users' OneDrive for Business storage limits are lower than expected.

More info: While the vast majority of impact associated with this event has been addressed, we remain committed to offering potential workarounds to those users who may still be affected.

For users that remain impacted, any quota which exceeds the 1TB storage, users may only be able to see their content in read-only mode.

Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes.

For users experiencing impact with custom quotas, we have provided an interim solution below while we work on developing a more robust solution. This solution was provided in an earlier communication and was not functioning properly, however, we have since addressed the issue.

We recommend admins attempt to manually set the quota for individual users. Instructions can be found here: https://docs.microsoft.com/en-us/onedrive/change-user-storage

We're expecting some users with custom and non-custom quotas may see a delay in mitigation. As such, all users can manually trigger a refresh through various actions within OneDrive to remediate any lingering impact. For example, accessing a OneDrive for Business account from the web or selecting a file within OneDrive will trigger such a refresh.

While we understand this may not be a viable option for all organizations, we're committed to providing all potential solutions to our customers.

Current status: Our telemetry data indicates that this issue has been resolved for the majority of users, and the subset of users still impacted are continuing to experience incremental relief. We’ll continue to monitor as we complete our refresh activities designed to resolve this issue without manual intervention on the part of individual users.

We understand how impacting this issue has been on your organization and we want to assure you that we are treating the issue with the utmost priority.

Scope of impact: This issue affects a large subset of users worldwide, who have a storage quota that exceeds 1TB.

Preliminary root cause: root cause: A misconfiguration resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.

Next update by: Thursday, September 9, 2021, 6:00 PM (11:00 PM UTC)
Posted Sep 09, 2021 - 14:29 CDT
Update
September 6, 2021 12:49 PM

Title: Users' OneDrive for Business storage limits are lower than expected

User Impact: Users' OneDrive for Business storage limits are lower than expected.

More info: For any quota which exceeds the 1TB storage, users may only be able to see their content in read-only mode.

Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes.

For users experiencing impact with custom quotas, we have provided an interim solution below while we work on developing a more robust solution. This solution was provided in an earlier communication and was not functioning properly, however, we have since addressed the issue.

We recommend admins attempt to manually set the quota for individual users. Instructions can be found here: https://docs.microsoft.com/en-us/onedrive/change-user-storage

We're expecting some users with non-custom quotas may see a delay in mitigation, and if necessary, they can expedite this process by navigating to their OneDrive for Business account via the web.

While we understand this may not be a viable option for all organizations, we're committed to providing all potential solutions to our customers.

Current status: We continue to perform the manual refresh activity, and approximately 40 percent of the remaining non-custom accounts have been completed.

Additionally, the fix that will address the custom quota impact continues deployment and has already been deployed to the majority of the service. We’ve activated the fix on 50 percent of the infrastructure that the fix has been deployed to, and expect the fix to be activated on 100 percent of the components within the next six hours.

We understand how impacting this issue has been on your organization and we want to assure you that we are treating the issue with the utmost priority.

Scope of impact: This issue affects a large subset of users worldwide, who have a storage quota that exceeds 1TB.

Preliminary root cause: root cause: A misconfiguration resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.

Next update by: Tuesday, September 7, 2021, 6:00 PM (11:00 PM UTC)
Posted Sep 07, 2021 - 07:54 CDT
Update
September 2, 2021 5:20 PM

Title: Users' OneDrive for Business storage limits are lower than expected

User Impact: Users' OneDrive for Business storage limits are lower than expected.

More info: For any quota which exceeds the 1TB storage, users may only be able to see their content in read-only mode.

Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes.

For users experiencing impact with custom quotas, we have provided an interim solution below while we work on developing a more robust solution. This solution was provided in an earlier communication and was not functioning properly, however, we have since addressed the issue.

We recommend admins attempt to manually set the quota for individual users. Instructions can be found here: https://docs.microsoft.com/en-us/onedrive/change-user-storage

We're expecting some users with non-custom quotas may see a delay in mitigation, and if necessary, they can expedite this process by navigating to their OneDrive for Business account via the web.

While we understand this may not be a viable option for all organizations, we're committed to providing all potential solutions to our customers.

Current status: The deployment is nearing completion, and we expect to begin post deployment validations by the end of day, September 2, 2021. Once the fix has taken full effect, both users with custom and non-custom quotas can manually trigger a refresh through various actions within OneDrive to resolve this issue. For example, by accessing their OneDrive for Business account from the web or selecting a file.

Our automatic refresh activity is on schedule to be completed and initiated by end of day, September 3, 2021.

We understand how impacting this issue has on your organization and we want to assure you that we are treating the issue with the utmost priority. We appreciate your patience and will continue to update the Service Health Dashboard daily.

Scope of impact: This issue affects a large subset of users worldwide, who have a storage quota that exceeds 1TB.

Preliminary root cause: A misconfiguration resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.

Next update by: Friday, September 3, 2021, 6:00 PM (11:00 PM UTC
Posted Sep 03, 2021 - 08:25 CDT
Update
August 30, 2021 5:36 PM

Title: Users' OneDrive for Business storage limits are lower than expected

User Impact: Users' OneDrive for Business storage limits are lower than expected.

More info: For any quota which exceeds the 1TB storage, users may only be able to see their content in read-only mode.

Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes.

For users experiencing impact with custom quotas we have provided an interim solution below while we work on developing a more robust solution. This solution was provided in an earlier communication and was not functioning properly, however, we have since addressed the issue.

We recommend admins attempt to manually set the quota for individual users. Instructions can be found here: https://docs.microsoft.com/en-us/onedrive/change-user-storage

For customers with non-set quotas, we're expecting some users may see a delay in mitigation, and if necessary, can expedite this process by navigating to their OneDrive for Business account via the web.

While we understand this may not be a viable option for all organizations, we're committed to providing all potential solutions to our customers.

Current status: In order to ensure we’re following safe deployment practices, we’re in the process of completing our final validations within our internal environments prior to initiating a targeted release. Our development of a mitigation activity to initiate an automated refresh is ongoing.

Our monitoring indicates users with a default or non-custom quota set continue to see relief.

We understand how impacting this issue has on your organization and we want to assure you that we are treating the issue with the utmost priority. We appreciate your patience and will continue to update the Service Health Dashboard daily.

Scope of impact: This issue affects a large subset of users worldwide, who have a storage quota that exceeds 1TB.

Preliminary root cause: A misconfiguration resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.

Next update by: Tuesday, August 31, 2021, 6:00 PM (11:00 PM UTC)
Posted Aug 31, 2021 - 07:28 CDT
Update
August 29, 2021 5:40 PM

Title: Users' OneDrive for Business storage limits are lower than expected

User Impact: Users' OneDrive for Business storage limits are lower than expected.

More info: For any quota which exceeds the 1TB storage, users may only be able to see their content in read-only mode. Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes. For users experiencing impact with custom quotas we have provided an interim solution below while we work on developing a more robust solution. This solution was provided in an earlier communication and was not functioning properly, however, we have since addressed the issue. We recommend admins attempt to manually set the quota for individual users. Instructions can be found here: https://docs.microsoft.com/en-us/onedrive/change-user-storage For customers with non-set quotas, we're expecting some users may see a delay in mitigation, and if necessary, can expedite this process by navigating to their OneDrive for Business account via the web. While we understand this may not be a viable option for all organizations, we're committed to providing all potential solutions to our customers.

Current status: We’ve completed development of the mitigation for users with custom quotas and are completing final validations prior to deployment. Additionally, our effort to develop a mitigation activity to initiate an automated refresh is ongoing. Our telemetry indicates the initial mitigation activity continues to provide relief for users with a default or non-custom quota set. We understand how impacting this issue has been on your organization and we want to assure you that we are treating the issue with the utmost priority. We appreciate your patience and will continue to update the Service Health Dashboard daily.

Scope of impact: This issue affects a large subset of users worldwide, who have a storage quota that exceeds 1TB. Preliminary root cause: A misconfiguration resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.

Next update by: Monday, August 30, 2021, 6:00 PM (11:00 PM UTC)
Posted Aug 30, 2021 - 07:26 CDT
Update
August 26, 2021 5:11 PM
Title: Users' OneDrive for Business storage limits are lower than expected



User Impact: Users' OneDrive for Business storage limits are lower than expected.



More info: For any quota which exceeds the 1TB storage quota, users may only be able to see their content in read-only mode.



Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes.



Current status: The deployment has completed successfully. Additionally, we’ve identified that the fix will take approximately 24 hours to take full effect. We’ll continue to closely monitor the environment during this timeframe to ensure the service remains in a healthy state, and that the fix progresses as intended.



Scope of impact: This issue affects a large subset of users worldwide.



Estimated time to resolution: Friday, August 27, 2021, 5:00 PM (10:00 PM UTC)



Preliminary root cause: A misconfiguration that resulted in our internal systems not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.



Next update by: Friday, August 27, 2021, 6:00 PM (11:00 PM UTC)
Posted Aug 27, 2021 - 16:15 CDT
Investigating
OD280960

Title: Users' OneDrive for Business storage limits are lower than expected

User Impact: Users' OneDrive for Business storage limits are lower than expected.

More info: For any quota which exceeds the 1TB storage quota, users may only be able to see their content in read-only mode.

Whilst in read-only mode, users can access their content in OneDrive for Business, but are unable to make changes.

We'd like to get your feedback on the workaround we provided. From a non-mobile device, please rate this post and submit it in the textbox.

Current status: We’ve initiated the deployment of the fix in a limited environment to ensure it resolves impact as expected. Once confirmed, we’ll proceed with expanding the deployment to all affected users. By design, this fix is expected to restore all affected users to the default storage quota of five terabytes.

Scope of impact: Further investigation has identified that this issue may impact users outside of the previously communicated timeframe, we apologize for any inconvenience or confusion this may have caused. Currently, our telemetry indicates that this issue affects a larger subset of users worldwide, including those not within the aforementioned criteria.

Preliminary root cause: An exception is not recognizing user licenses and reverting the storage quota limit to the default settings of 1TB.

Next update by: Thursday, August 26, 2021, at 9:00 PM UTC
Posted Aug 26, 2021 - 16:03 CDT
This incident affected: Office 365.