Unable to access Customer Portal
Incident Report for Zix | AppRiver
Resolved
We have resolved the issue and are confirming successful traffic back to our Customer Portal. We apologize for any inconvenience this may have caused.
Posted Mar 27, 2023 - 10:44 CDT
Identified
We have identified and are working on resolving an issue in which you cannot access our Customer Portal. We will update this one this issue has resolved. We apologize for any inconvenience this may be causing.
Posted Mar 27, 2023 - 08:57 CDT
This incident affected: Customer Portal Interface (Customer Portal).