Hex incoming mails not being delivered
Incident Report for
Zix | AppRiver
Resolved
This incident has been resolved.
Posted
Nov
06
,
2024
-
02:47
CST
Investigating
Currently, we are experiencing issues with incoming emails not being delivered with our hex system. Our team is investigating.
Posted
Nov
06
,
2024
-
01:50
CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).
×
Subscribe to Incident
Subscribe to updates for
Hex incoming mails not being delivered
via . You'll receive .