Exchange Delays
Incident Report for AppRiver
Postmortem

Exchange delays experienced on 04 March 2019 were the result of an inefficient route design that was discovered during preparations for a required datacenter migration. Working with the datacenter engineers, we were able to uncover a bad static route that was incorrectly directing traffic through the network. Once the route was identified and correctly routed, the network completely stabilized.

Partners - for more details, click here.

Posted 3 months ago. Mar 06, 2019 - 13:06 CST

Resolved
Last night, our engineers were able to isolate and successfully resolve the issue that was causing Exchange delays. After monitoring through the night, we are confident in the resolution and will post more on the Root Cause Analysis as soon as it has been completed.
Posted 3 months ago. Mar 05, 2019 - 08:33 CST
Update
Queues have cleared and mail is currently flowing as expected. Our engineers are still working with the datacenter to further isolate the latency issue that has been occurring.
Posted 3 months ago. Mar 04, 2019 - 14:25 CST
Update
We are working with our provider to rectify the issue that is causing Exchange delivery to be delayed. Queues are clearing out as a result of the increased throughput, but is still taking time to process. We’ll continue to update status as we work to a resolution.
Posted 3 months ago. Mar 04, 2019 - 12:23 CST
Update
Over the past weekend, we worked in conjunction with one of our datacenter providers to update configurations required for maintenance. The complete maintenance process was delayed due to unforeseen circumstances and our Exchange service has experienced delays as a result. We have worked with our provider to increase the throughput to counteract any latency, and queue delays are decreasing accordingly - although we do expect possible delays to continue as the mail delivery queues continue to work through the backlog. We’ll post more on this issue in the next hour or so.
Posted 3 months ago. Mar 04, 2019 - 10:47 CST
Identified
The issue that is impacting Exchange delays has been identified and we’re working on implementing a corrective action.
Posted 3 months ago. Mar 04, 2019 - 09:24 CST
Investigating
Our team is currently investigating delays impacting Exchange, particularly with larger attachments.
Posted 3 months ago. Mar 04, 2019 - 07:17 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).