Information Archive
Incident Report for Zix | AppRiver
Resolved
The issue with Information Archive has been resolved.
Posted Sep 14, 2023 - 15:07 CDT
Investigating
We are currently investigating issues with accessing Information Archive. The error that is being seen is Error 500 "oops, something went wrong".
Posted Sep 14, 2023 - 14:25 CDT
This incident affected: Archive Services (Information Archive / ZCP).