Disabling Support for TLS 1.0 and 1.1 Hosted Exchange
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 15:04 CST
Monitoring
What changes is occurring?
On October 1st 2022, Hosted Exchange will be disabling TLS 1.0 and TLS 1.1 and moving all of our online services to TLS 1.2.

How does this affect me?
As of October 1, 2022, Hosted Exchange will no longer support TLS 1.0 and 1.1. By October 1, 2022, all client and browser combinations should use TLS version 1.2 (or a later version) to ensure connection without issues to our services. This may require updates to certain clients and browser combinations. If you do not update to TLS version 1.2 (or later) by October 1, 2022, you may experience issues when connecting to Hosted Exchange. If you experience an issue related to the use of an old TLS version after October 1, 2022, you will be required to update to TLS 1.2 as part of the resolution.

What do I need to do to prepare for this change?
We recommend you proactively address weak TLS usage by removing TLS 1.0/1.1 dependencies in your environments and disabling TLS 1.0/1.1 at the operating system level where possible. Clients using Outlook 2010 for Windows or Outlook 2011 for Mac will need to change to be replaced with newer versions. Clients using Outlook 2013 SP1 (or higher), Outlook 2016 for Mac will need to ensure that they are up to date. Windows 7 users can use TLS 1.2 client applications and browsers if changes are made using the following Microsoft guidance at Update to enable TLS 1.1 and TLS 1.2 as default secure protocols in WinHTTP in Windows (microsoft.com).
Posted Jul 14, 2022 - 16:13 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).