Delayed inbound mail to @zixcorp.com
Incident Report for Zix | AppRiver
Resolved
Hello,

We have monitored this for several days we are not seeing any delays for email recipients with the domain of @zixcorp.com.

This matter is considered closed and we do apologize for any inconvenience.
Posted Mar 17, 2023 - 10:34 CDT
Monitoring
Hello,

The issue of delayed email to @zixcorp.com email addresses appears to have cleared at about 10:30 PM Central on 14 Mar. We will keep this status open in a "Monitoring" state for the time being as this is the 2nd iteration of the event.
Posted Mar 15, 2023 - 09:03 CDT
Identified
Microsoft has started to defer email inbound to @zixcorp.com. We are currently working with our engineers and Microsoft to resolve the issue.

We do apologize for any inconvenience. If your issue is an emergency you can contact us at 888.576.4949 or if you are wishing to just email in a ticket you can use support@appriver.com.

Thank you
Posted Mar 14, 2023 - 15:39 CDT
This incident affected: Support Infrastructure (Support Ticketing System).