Zix|Appriver UK Phone Number Change
Incident Report for
Zix | AppRiver
Update
.
Posted
Jun
16
,
2023
-
13:18
CDT
Monitoring
We will be transitioning away from the current UK phone number of +44 20 3588 6180.
The new UK phone number will be +44 20 3849 4400
The new phone number is already working, so please make note of this new number as we transition away from the old.
Posted
Jun
05
,
2023
-
08:23
CDT
This incident affects: Support Infrastructure (Phone System).
×
Subscribe to Incident
Subscribe to updates for
Zix|Appriver UK Phone Number Change
via . You'll receive .