Inablity to log into the Customer Portal
Incident Report for Zix | AppRiver
Resolved
This incident has been fully resolved.
Posted Feb 14, 2024 - 08:21 CST
Identified
We are investigating an issue in which customers are unable to log into the Customer Portal in which an error is being presented on logging in. We apologize for any inconvenience this may currently be causing.
Posted Feb 11, 2024 - 09:17 CST
This incident affected: Customer Portal Interface (Customer Portal).