Phone/IVR issues
Incident Report for AppRiver
Resolved
This issue has been resolved. We have confirmed all inbound calls are routing correctly now. We apologize for any inconvenience this may have caused.
Posted Apr 12, 2021 - 13:08 CDT
Investigating
We are currently investigating an issue with call quality with our phone provider. If you need immediate assistance please email to support@appriver.com.
Posted Apr 12, 2021 - 10:47 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).