Experiencing Issues with Primary Remote Tool for Support
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted May 20, 2023 - 11:34 CDT
Investigating
We are currently experiencing issues using our main remote tool for supporting via screen share. As a result, this may limit our capability to remote into devices to provide remote support. We are currently investigating this issue and will provide an update as soon as possible.
Posted May 20, 2023 - 10:37 CDT