Inbound Phone/IVR issues
Incident Report for AppRiver
Resolved
We have confirmed the issue has been resolved by our phone provider. We are continuing to monitor the inbound phones to confirm everything is operational. We apologize for any inconvenience this may have caused this morning.
Posted Apr 26, 2021 - 11:31 CDT
Investigating
We are currently investigating an issue with our phone system and are actively working with our phone provider for resolution. If you have an immediate need you please email support@appriver.com. We apologize for the inconvenience this may have caused.
Posted Apr 26, 2021 - 09:47 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).