Microsoft 365 - Outlook freezing or crashing
Incident Report for Zix | AppRiver
Resolved
Microsoft has resolved this incident.
Posted Oct 11, 2024 - 08:27 CDT
Monitoring
Updated from Microsoft:

We’ve applied a configuration update and our testing indicates that this action has successfully mitigated impact. However, affected users will need to take action to apply the changes we’ve made and remediate the problem:

- Outlook client and app users should restart their client or app to apply our changes. Outlook desktop client users may need to perform this action twice due to caching issues.

- Outlook on the web users should refresh their sessions. If that does not mitigate the issue, users are encouraged to clear their browser cache and refresh their Outlook on the web session.
Posted Oct 10, 2024 - 13:44 CDT
Update
We are continuing to investigate this issue.
Posted Oct 10, 2024 - 12:26 CDT
Investigating
Service Alert posted by Microsoft:

Users may notice Outlook using an increased amount of system resources, causing the client to freeze or crash.

Impact is predominately to the Outlook client, though users of any connection method including Outlook on the web and Outlook mobile apps may be affected.

Our investigation is presently focused on an issue affecting a separate portion of our service infrastructure as the likely cause of impact. We’re working on a potential solution and are preparing to apply a targeted configuration update that we suspect will alleviate the impact.
Posted Oct 10, 2024 - 12:26 CDT
This incident affected: Office 365.