Mail delays in Secure cloud encryption
Incident Report for Zix | AppRiver
Resolved
The delays have been rectified. If you are still experiencing an issue please contact support.
Posted Sep 26, 2024 - 13:58 CDT
Investigating
We are currently investigating mail delays in our Secure cloud email encryption environment. A high severity ticket has been raised and the engineers are currently investigating.
Posted Sep 26, 2024 - 11:59 CDT
This incident affected: Encryption Services (Secure Cloud Email Encryption (AEE/ZEE)).