HEX users in USA unable to access OWA
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted May 19, 2023 - 10:19 CDT
Monitoring
OWA is now accessible, and we will continue to monitor
Posted May 19, 2023 - 08:00 CDT
Investigating
We have identified an issue where users are unable to access OWA for Hosted Exchange. We are aware of the issue and diligently working towards a resolution. We apologize for the inconvenience and appreciate your patience. We will update status as we have more information.
Posted May 18, 2023 - 21:36 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).