Currently Customer Portal is down and is not responding
Incident Report for Zix | AppRiver
Resolved
We have confirmed the issue was resolved as of 8/20 at 8:30 PM CST.
Posted Aug 21, 2024 - 07:28 CDT
Update
We are continuing to investigate this issue.
Posted Aug 20, 2024 - 21:23 CDT
Investigating
We are currently investigating this issue.
Posted Aug 20, 2024 - 18:57 CDT
This incident affected: Customer Portal Interface (Customer Portal).