Usage Reports
Incident Report for Zix | AppRiver
Resolved
Our engineers have found the issue and implemented a fix.
Posted Oct 10, 2023 - 07:32 CDT
Identified
Our CloudAlly Backup engineering team has identified and working on the issue of some customers not receiving their usage reports. We will update this notification as updates become available.
Posted Oct 02, 2023 - 08:28 CDT
This incident affected: CloudAlly Backup.