Support Toll Free Number
Incident Report for Zix | AppRiver
Resolved
Hello,

Support is no longer receiving reports the toll-free number dialed from service providers (other than t-mobile) could not connect.

This issue is considered to be closed and we do apologize for any inconvenience.
Posted Mar 17, 2023 - 10:32 CDT
Identified
Hello,

We are receiving reports that certain service providers are having issues connecting with our toll-free 888.576.4949 phone line. The Support line is working just not from certain service providers.

If you are experiencing this issue, please call 850-932-5338 as an alternate number.

Thank you
Posted Mar 16, 2023 - 12:37 CDT
This incident affected: Support Infrastructure (Phone System).