Zurich Data Center issue
Incident Report for Zix | AppRiver
Resolved
All services have been restored to operational status. We apologize for any inconvenience this may have caused.
Posted May 17, 2022 - 17:23 CDT
Investigating
We are currently experiences issues with our Zurich Data Center and are actively investigating this issue with our vendor. This will effect access for some EMEA customers and their access to our Hosted Exchange/ETP filtering and our EMP products lines. We apologize for any inconvenience this may be causing. We will follow with another update as soon as more information is available.
Posted May 17, 2022 - 17:01 CDT
This incident affected: Encryption Services (EMP/DeliverySlip), Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)), and Threat Protection (Email Threat Protection).