Erado SecureMail not delivering emails to recipients
Incident Report for
Zix | AppRiver
Resolved
Our engineers have located the issue and resolved the problem so that the system can be returned to operational status.
Posted
Sep
24
,
2024
-
16:10
CDT
Update
We have rerouted mail flow to other servers and are continuing to troubleshoot underlying issue.
Posted
Sep
24
,
2024
-
14:57
CDT
Investigating
We are currently investigating reported issue with Erado secure not being sent to recipients.
Posted
Sep
24
,
2024
-
14:56
CDT
This incident affected: Archive Services (Information Archive / ZCP).
×
Subscribe to Incident
Subscribe to updates for
Erado SecureMail not delivering emails to recipients
via . You'll receive .