Experiencing issues with EMP/DeliverySlip EMEA
Incident Report for Zix | AppRiver
Resolved
Hello,

This issue was found and resolved. We do apologize for the inconvenience of this issue.

Thank you
Posted May 26, 2023 - 07:35 CDT
Investigating
We are currently experiencing issues with EMP/DeliverySlip. We are currently investigating.
Posted May 26, 2023 - 05:54 CDT
This incident affected: Encryption Services (EMP/DeliverySlip).