We are only seeing the normal rejects expected this morning. This matter is considered to be resolved.
Posted Aug 02, 2024 - 06:30 CDT
Monitoring
Mimecast has resolved the issue on their end, we have also restarted our name services and the change is in effect. There is a propagation time that might affect the service. We already see most emails processing through our system. We are still monitoring.
Posted Aug 01, 2024 - 21:26 CDT
Identified
The possible issue has been identified as extra quotes in the US blocks of Mimecast's SPF records. It is recommended that the sender of blocked email contact Mimecast Support about the DNS misconfiguration.
Posted Aug 01, 2024 - 15:42 CDT
Investigating
Hello,
We are experiencing an issue where mail sent to our SMB encryption system from Mimecast is blocked. We are currently investigating the issue.
Posted Aug 01, 2024 - 14:47 CDT
This incident affected: Encryption Services (Hosted SMB).