Hosted Exchange (HEX) incoming mail delays
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Aug 16, 2024 - 13:47 CDT
Monitoring
Our engineering team was able to resolve the issue, and the impacted mailboxes should now be receiving the previous delayed email. We are currently monitoring.
Posted Aug 16, 2024 - 09:08 CDT
Investigating
We are receiving reports of incoming mail delays. Our team is actively investigating the issue.
Posted Aug 16, 2024 - 08:47 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).