The final fixes were deployed Friday 2/28/2025. We are continuing to the monitor the system. Please contact support if you are running into any further issues.
Posted Mar 05, 2025 - 07:28 CST
Update
We are continuing to work on a fix for this issue.
Posted Feb 26, 2025 - 12:59 CST
Update
We are receiving some reports of the issue occurring at this time. Our engineering team is investigating and making further adjustments.
Posted Feb 25, 2025 - 08:51 CST
Update
The process is complete, the fix should be applied to all impacted mailboxes. We are currently monitoring. Please contact support if you are running into any further issues.
Posted Feb 24, 2025 - 07:18 CST
Update
Resolution is being applied to affected mailboxes. It may take a bit of time for the process to complete. Will update once the process is completed.
Posted Feb 21, 2025 - 13:36 CST
Update
We are continuing to work on a fix for this issue.
Posted Feb 20, 2025 - 16:20 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2025 - 10:49 CST
Update
Our Engineering team is continuing to investigate this issue
Posted Feb 19, 2025 - 15:35 CST
Investigating
We are aware of an issue with IMAP and POP clients receiving “550 5.7.60 smtp, client does not have permissions to send as this sender” error when sending from outlook.