Experiencing Issues with SignNow
Incident Report for Zix | AppRiver
Resolved
The issue with SignNow has been resolved. We do apologize for any inconvenience.

Thank you
Posted Apr 25, 2023 - 15:17 CDT
Investigating
We are currently looking into the issue with SignNow services used for Erado Archiving service modifications. Archiving is not affected.
Posted Apr 25, 2023 - 09:08 CDT
This incident affected: Archive Services (Erado Archiving).