Phone Issue
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted Jan 11, 2021 - 07:16 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2021 - 07:16 CST
Investigating
We are currently investigating reports of an issue with our primary support toll-free number, which began at approximately 9:00 AM central. During this time please email support@appriver.com. Our provider is working on the issue and we expect this to be resolved shortly. We apologize for any inconvenience this may cause.
Posted Jan 04, 2021 - 10:16 CST
This incident affected: Support Infrastructure (AppRiver Phone System).