Inbound mail flow issues
Incident Report for Zix | AppRiver
Resolved
We have resolved the root issue for the inbound email issue and we determined it affected a small subset of customers on a particular server set. We apologize for the inconvenience this may have caused.
Posted Oct 12, 2021 - 15:43 CDT
Investigating
We are currently investigating an issue with inbound emails not properly being delivered. We are working on resolving this currently. We apologize for any inconvenience this may be currently causing.
Posted Oct 12, 2021 - 14:58 CDT
This incident affected: Threat Protection (Email Threat Protection).