Unable to access Microsoft 365 admin center

Incident Report for Zix | AppRiver

Resolved

This incident has been resolved.
Posted Jan 29, 2025 - 14:45 CST

Monitoring

We are receiving reports that the admin center is successfully reconnecting now and have confirmed through testing from our end.
Posted Jan 29, 2025 - 12:46 CST

Investigating

We are receiving some reports that admins are unable to access the Microsoft 365 admin center.

We are checking for any information provided by Microsoft regarding this reported issue and will provide a further update as soon as possible.
Posted Jan 29, 2025 - 12:20 CST
This incident affected: Office 365.