Customer Portal Issues
Incident Report for AppRiver
Resolved
We have rectified the issue and confirmed we are handling all log-in attempts successfully. We apologize for any inconvenience this may have caused.
Posted Sep 15, 2021 - 10:55 CDT
Identified
We are investigating an issue where users are currently unable to login to the Customer Portal.

We apologize for the inconvenience and will post updates as soon as we have more information.
Posted Sep 15, 2021 - 08:00 CDT
This incident affected: Secure Cloud Platform (Customer Portal, Partner Portal).