EMP (DeliverySlip)
Incident Report for Zix | AppRiver
Resolved
The issues with EMP has been resolved and it back in working order. If you are continuing to experience issues please contact our support team.
Posted Jul 05, 2024 - 08:07 CDT
Investigating
We have received reports that our DeliverySlip portals are experiencing issues ranging from being inaccessible to not being able to upload attachments . We have raised a high severity ticket and our engineers are currently investigating. We will continue to update this status as soon as updates come available.
Posted Jul 03, 2024 - 09:41 CDT
This incident affected: Encryption Services (EMP/DeliverySlip).