We have confirmed that Micrsoft Smart Screen is not currently blocking our Link Protection wrap (link.edgepilot.com) and we are continuing to monitor to ensure no further issues are reported.
Posted Aug 16, 2024 - 14:02 CDT
Update
We are continuing to work with Microsoft on the de-listing of our link wrap URL. In the interim, you can use a 3rd party such as Chrome/Firefox to work around this issue. You can also disable the Smart Screen detection within Edge under the Settings->Privacy section of the browser settings. You can also confirming to pass through to the link by selection "More Information"->Procced.
For Outlook clients, you can also setup the default processing following the below steps.
File > Options > Advanced > "File and Browser Preferences" - "Open hyperlinks from Outlook in:" Set to Default
Posted Aug 15, 2024 - 06:44 CDT
Identified
We have identified what appears to be an issue with Microsoft inadvertently marking our Link Protection wrapping URL as malicious. We have requested a de-list and are engaged with Microsoft. This appears to only effect the Microsoft Edge browser. As a workaround other browser will open the links without issue.
Posted Aug 14, 2024 - 08:38 CDT
Update
We are continuing to investigate this issue.
Posted Aug 14, 2024 - 00:58 CDT
Investigating
link.edgepilot.com is being blocked by MS Defender SmartScreen
Posted Aug 14, 2024 - 00:58 CDT
This incident affected: Threat Protection (Email Threat Protection).