MS Service Incident: Admins may be unable to access the Exchange admin center
Incident Report for Zix | AppRiver
Resolved
Final status: We've confirmed with reporting users and though monitoring service telemetry that reverting the offending update has successfully remediated impact.
Posted Jan 16, 2024 - 11:38 CST
Monitoring
Current status: We've identified that a recently scheduled update intended to perform standard service maintenance, unexpectedly caused an error, preventing admins from being able to access the Exchange admin center (EAC). We've reverted the offending update and are now monitoring the service health telemetry to confirm if it has remediated impact.

Root cause: A recent scheduled update intended to perform standard service maintenance, unexpectedly caused an error, preventing admins from being able to access the Exchange admin center (EAC).

Next update by: Tuesday, January 16, 2024 at 12:30 PM CST
Posted Jan 16, 2024 - 10:41 CST
Update
Current status: We're continuing to review service monitoring telemetry to isolate the source of the impact. In addition, we're reaching out to the affected users to request further diagnostic data in order to help us better understand the issue and formulate a mitigation plan.

Next update by: Tuesday, January 16, 2024 at 10:30 AM CST
Posted Jan 16, 2024 - 08:51 CST
Investigating
Microsoft has posted the following service incident -

Title: Admins may be unable to access the Exchange admin center

User impact: Admins may be unable to access the Exchange admin center.

Current status: We're reviewing service monitoring telemetry to isolate the source of the issue and establish a fix.

Scope of impact: Impact is specific to admins who are served through the affected infrastructure.

Next update by: Tuesday, January 16, 2024 at 8:30 AM CST
Posted Jan 16, 2024 - 08:22 CST
This incident affected: Office 365.