Microsoft Licensing quantities affecting new subscription orders

Incident Report for Zix | AppRiver

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 13:29 CST

Investigating

We're aware of an issue when placing new orders and modifying license quantities, Microsoft is currently experiencing an outage affecting all subscription operations. Please contact o365operations@appriver.com for further assistance.
Posted Feb 19, 2025 - 08:51 CST
This incident affected: Office 365.