SecureSurf issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 13, 2018 - 15:12 CDT
Investigating
Our team is currently investigating a SecureSurf issue that is causing the Web Protection tab in the Customer Portal to error, however, the service itself is still fully operational. This page will be updated once we have more information.
Posted 6 months ago. Apr 13, 2018 - 14:40 CDT