MFA Login Issues with Office 365
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 15 days ago. Nov 26, 2018 - 14:49 CST
Monitoring
Microsoft has identified the root cause of the MFA login issue and is continuing to monitor the situation to ensure impact has been remediated. Status is still being updated at https://status.office365.com/.
Posted 21 days ago. Nov 20, 2018 - 09:09 CST
Identified
Microsoft is currently experiencing Multi-Factor Authentication (MFA) issues with Office 365 accounts, resulting in the inability for some users to login. Microsoft is aware of the issue and is updating status at https://status.office365.com/.
Posted 22 days ago. Nov 19, 2018 - 09:52 CST
This incident affected: Office 365.