EXG7 issue
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted 12 months ago. Mar 05, 2018 - 11:42 CST
Investigating
Our team is currently investigating an issue with EXG7 that may prevent users from receiving external emails. We will update this page once we have more information.
Posted 12 months ago. Mar 05, 2018 - 08:48 CST