Phone System Down
Incident Report for AppRiver LLC
Resolved
All phone lines should be fully operational.
Posted 11 days ago. Oct 11, 2018 - 08:15 CDT
Identified
An ISP issue caused AppRiver's phones to be temporarily unavailable. Customers may still reach our support team via email or chat.
Posted 11 days ago. Oct 11, 2018 - 08:07 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).