Smarthost delays
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 18, 2017 - 09:52 CDT
Identified
SecureTide customers with Smarthost may currently be experiencing outbound mail delays. Our team has identified the root cause and normal outbound mail flow should resume shortly.
Posted about 1 year ago. Sep 18, 2017 - 09:45 CDT