Comcast connectivity issue
Incident Report for AppRiver LLC
Resolved
Comcast's connectivity issue should now be resolved for most customers.
Posted 12 months ago. Nov 06, 2017 - 14:55 CST
Investigating
Comcast is currently experiencing a connectivity issue which may result in the inability for some AppRiver customers to send or receive mail, as a lot of email traffic is routed through their system. We will update this page as soon as we have more information.
Posted 12 months ago. Nov 06, 2017 - 12:36 CST