Phone Outage 19 Jan 2019
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 19, 2019 - 12:47 CST
Update
Phone service has been restored but we are still experiencing an intermittent internet outage and are investigating further. However, customer services are not impacted by the outage.
Posted about 1 month ago. Jan 19, 2019 - 09:18 CST
Investigating
We are experiencing a phone service outage and are currently investigating the issue.
Posted about 1 month ago. Jan 19, 2019 - 08:56 CST
This incident affected: Support Infrastructure (AppRiver Phone System).