Mail delays
Incident Report for AppRiver LLC
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 27, 2017 - 14:15 CDT
Investigating
Our networking team is currently investigating an issue related to one of our delivery servers. This issue may result in mail delays for a subset of AppRiver customers. We will update this page once we have more information.
Posted over 1 year ago. Apr 27, 2017 - 09:49 CDT