Mail Flow Delays
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 12, 2019 - 13:03 CDT
Update
Our team is continuing to monitor the queues.
Posted 5 months ago. Jun 04, 2019 - 15:52 CDT
Update
Progress has been made, however, we are continuing to monitor the issue. This page will be updated with more information as soon as we have it.
Posted 5 months ago. Jun 04, 2019 - 11:28 CDT
Update
Investigating - Some AppRiver customers are reporting mail flow delays. Our team is investigating and we will report back here with more information as we have it.
Posted 5 months ago. Jun 04, 2019 - 10:19 CDT
Monitoring
AppRiver's engineering team discovered that DNS resolution issues were causing the mail delays experienced earlier today. They have now pushed out a fix and mail is flowing normally. The team will continue to monitor mail flow to ensure there are no lingering issues.
Posted 5 months ago. May 31, 2019 - 15:32 CDT
Update
Our team has rolled back a recent software update and mail flow appears to be stabilized. However, our engineers are investigating further to rule out other possible causes.
Posted 5 months ago. May 31, 2019 - 13:33 CDT
Update
Our engineers are still working to resolve the mail flow delays that have been reported by some of our customers. So far, the issue appears to be unrelated to the earlier delays. We will update here when we have more information.
Posted 5 months ago. May 31, 2019 - 12:31 CDT
Investigating
Some AppRiver customers are reporting mail flow delays. Our team is investigating and we will report back here with more information as we have it.
Posted 5 months ago. May 31, 2019 - 11:43 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)) and Email Security.