Exchange Online Messages going to Junk
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 16:14 CDT
Update
Title: Inbound email is being routed to the junk folder

ID: EX258373

Status
Service Restored

Details

Title: Inbound email is being routed to the junk folder

User Impact: Users may have observed that incoming mail was being routed to their junk folder.

More info: Within Threat Explorer, admins may have observed delayed message state updates for messages that were reprocessed during our mitigation efforts.

Final status: We've processed all affected messages and confirmed that this issue is mitigated.
Scope of impact: Any users that received inbound mail between 7:50 PM UTC and 10:15 PM UTC on May 26, 2021, were affected. While the majority of this mail was delivered, a small percentage of these impacted messages took an extended period of time to process.

Start time: Wednesday, May 26, 2021, at 7:50 PM UTC

End time: Thursday, May 27, 2021, at 10:15 PM UTC

Preliminary root cause: A recent change resulted in an issue wherein inbound email was being incorrectly routed to the junk folder.

Next steps:
- We're reviewing our standard change procedures to find ways to prevent this problem from happening again.
Posted May 27, 2021 - 21:25 CDT
Identified
Title: Inbound email is being routed to the junk folder

User Impact: Users may observe that incoming mail is being routed to their junk folder.

More info: Within Threat Explorer, admins may observe delayed message state updates for messages that were reprocessed during our mitigation effort.

Current status: We've processed 98.5 percent of all impacted messages and expect that the remaining 1.5 percent will be completed within the next few hours.

Scope of impact: Any users that received inbound mail between 7:50 PM and 10:15 PM on May 26, 2021 is affected. While the majority of this mail has been delivered, a small percentage of these impacted message are still being processed.

Start time: Wednesday, May 26, 2021, 2:50 PM (7:50 PM UTC)

Estimated time to resolve: Thursday, May 27, 2021 at 9:00 PM UTC

Preliminary root cause: A recent change has resulted in an issue in which inbound email is being incorrectly routed to the junk folder.

Next update by: Thursday, May 27, 2021, 6:00 PM (11:00 PM UTC)
Posted May 27, 2021 - 16:19 CDT
Investigating
Advisory information

Title: We're looking into a potential problem

ID: EX258373

Status
Investigating

Details

Title: We're looking into a potential problem

User Impact: MS Office 365 users may observe that incoming mail is being routed to their junk folder.

Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.


Thank you,
The Microsoft team
Posted May 26, 2021 - 16:31 CDT
This incident affected: Office 365.